BUS_ADD_CHILD man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

BUS_ADD_CHILD(9)	 BSD Kernel Developer's Manual	      BUS_ADD_CHILD(9)

NAME
     BUS_ADD_CHILD — add a device node to the tree with a given priority

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     BUS_ADD_CHILD(device_t parent, device_t child, int order,
	 const char *name, int unit);

DESCRIPTION
     The BUS_ADD_CHILD() method is used by the driver identify routine to add
     devices to the tree.  Please see device_add_child(9) for more details.
     The interface is similar to device_add_child(9) however, the bus'
     BUS_ADD_CHILD() is called.

     Busses implementing BUS_ADD_CHILD() should insert the device into the
     tree using device_add_child(9) before adding things such as their own
     ivars and resource lists to the device.

RETURN VALUES
     The BUS_ADD_CHILD() method returns device_t added to the tree, or NULL.

SEE ALSO
     device(9), device_add_child(9), driver(9)

AUTHORS
     This manual page was written by M. Warner Losh.

BSD			       December 20, 2009			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net