vm_page_wire man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VM_PAGE_WIRE(9)		 BSD Kernel Developer's Manual	       VM_PAGE_WIRE(9)

NAME
     vm_page_wire, vm_page_unwire — wire and unwire pages

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     void
     vm_page_wire(vm_page_t m);

     void
     vm_page_unwire(vm_page_t m, int activate);

DESCRIPTION
     The vm_page_wire() function increments the wire count on a page, and
     removes it from whatever queue it is on.

     The vm_page_unwire() function releases one of the wirings on the page.
     When write_count reaches zero the page is placed back onto either the
     active queue (if activate is non-zero) or onto the inactive queue (if
     activate is zero).	 If the page is unmanaged (PG_UNMANAGED is set) then
     the page is left on PQ_NONE.

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 13, 2001				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net