POOLD(1M)POOLD(1M)NAMEpoold - automated resource pools partitioning daemon
SYNOPSISpoold [-l level]
DESCRIPTIONpoold provides automated resource partitioning facilities. poold can be
enabled or disabled using the Solaris Service Management Facility,
smf(5). poold requires the Resource Pools facility to be active in
order to operate.
The dynamic resource pools service's fault management resource identi‐
fier (FMRI) is:
The resource pools service's FMRI is:
poold's configuration details are held in a libpool(3LIB) configuration
and you can access all customizable behavior from this configuration.
poold periodically examines the load on the system and decides whether
intervention is required to maintain optimal system performance with
respect to resource consumption. poold also responds to externally ini‐
tiated (with respect to poold) changes of either resource configuration
If intervention is required, poold attempts to reallocate the available
resources to ensure that performance objectives are satisfied. If it is
not possible for poold to meet performance objectives with the avail‐
able resources, then a message is written to the log. poold allocates
scarce resources according to the objectives configured by the adminis‐
trator. The system administrator must determine which resource pools
are most deserving of scarce resource and indicate this through the
importance of resource pools and objectives.
The following options are supported:
Specify the vebosity level for logging information.
Specify level as ALERT, CRIT, ERR, WARNING, NOTICE, INFO,
and DEBUG. If level is not supplied, then the default log‐
ging level is INFO.
A condition that should be corrected immedi‐
ately, such as a corrupted system database.
Critical conditions, such as hard device errors.
Conditions that are not error conditions, but
that may require special handling.
Messages that contain information normally of
use only when debugging a program.
When invoked manually, with the -l option, all log output is directed
to standard error.
Example 1 Modifying the Default Logging Level
The following command modifies the default logging level to ERR:
# /usr/lib/pool/poold -l ERR
Example 2 Enabling Dynamic Resource Pools
The following command enables dynamic resource pools:
# /usr/sbin/svcadm enable svc:/system/pools/dynamic
See attributes(5) for descriptions of the following attributes:
│ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
│Interface Stability │ See below. │
The invocation is Evolving. The output is Unstable.
SEE ALSOpooladm(1M), poolbind(1M), poolcfg(1M), poolstat(1M), svcadm(1M),
pool_set_status(3POOL), libpool(3LIB), attributes(5), smf(5)
Dec 1, 2005 POOLD(1M)