mountall, umountall - mount, unmount multiple file systems
SYNOPSISmountall [-F FSType] [-l | -r] [file_system_table]
umountall [-k] [-s] [-F FSType] [-l | -r] [-n] [-Z]
umountall [-k] [-s] [-h host] [-n] [-Z]
DESCRIPTIONmountall is used to mount file systems specified in a file system ta‐
ble. The file system table must be in vfstab(4) format. If no
file_system_table is specified, /etc/vfstab is used. If − is specified
as file_system_table, mountall reads the file system table from the
standard input. mountall mounts only those file systems with the mount
at boot field set to yes in the file_system_table.
For each file system in the file system table, the following logic is
executed: if there exists a file/usr/lib/fs/FSType/fsckall, where
FSType is the type of the file system, save that file system in a list
to be passed later, and all at once, as arguments to the
/usr/lib/fs/FSType/fsckall script. The /usr/lib/fs/FSType/fsckall
script checks all of the file systems in its argument list to determine
whether they can be safely mounted. If no /usr/lib/fs/FSType/fsckall
script exists for the FSType of the file system, the file system is
individually checked using fsck(1M). If the file system does not
appear mountable, it is fixed using fsck before the mount is attempted.
File systems with a − entry in the fsckdev field are mounted without
first being checked.
umountall causes all mounted file systems in the current zone except
root, /usr, /var, /var/adm, /var/run, /proc, and /dev/fd to be
unmounted. If the FSType is specified, mountall and umountall limit
their actions to the FSType specified. There is no guarantee that
umountall unmounts busy file systems, even if the -k option is speci‐
The following options are supported:
Specify the FSType of the file system to be mounted or
Unmount all file systems listed in /etc/mnttab that are
remote-mounted from host.
Use the fuser -k mount-point command. See the fuser(1M) for
details. The -k option sends the SIGKILL signal to each
process using the file. As this option spawns kills for each
process, the kill messages might not show up immediately.
There is no guarantee that umountall unmounts busy file sys‐
tems, even if the -k option is specified.
Limit the action to local file systems.
List the actions that would be performed for the specified
options, but do not actually execute these actions. Repeat‐
ing the command without the -n option executes the listed
actions, assuming that the /etc/mnttab file has not changed
in the interval prior to repeating the command.
Limit the action to remote file system types.
Do not perform the umount operation in parallel.
Apply the action(s) only to the file systems mounted in
non-global zones. By default, umountall unmounts only file
systems mounted in the current zone. Option -Z is ignored if
used in a non-global zone.
Mounted file system table
Table of file system defaults
Script called by mountall to perform the file system check of all
file systems of type FSType
See attributes(5) for descriptions of the following attributes:
│ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
│Interface Stability │ Committed │
│Output Stability │ Uncommitted │
SEE ALSOfsck(1M), fuser(1M), mount(1M), mnttab(4), vfstab(4), attributes(5)DIAGNOSTICS
No messages are printed if the file systems are mountable and clean.
Error and warning messages come from fsck(1M) and mount(1M).
At this time, NFS is the only remote file system supported by the -l,
-r, and -h options.
Dec 17, 2008 MOUNTALL(1M)