cpu_reboot man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

CPU_REBOOT(9)		 BSD Kernel Developer's Manual		 CPU_REBOOT(9)

NAME
     cpu_reboot — halt or reboot the system

SYNOPSIS
     #include <sys/reboot.h>

     void
     cpu_reboot(int howto, char *bootstr);

DESCRIPTION
     The cpu_reboot() function handles final system shutdown, and either halts
     or reboots the system.  The exact action to be taken is determined by the
     flags passed in howto and by whether or not the system has finished auto‐
     configuration.

     If the system has finished autoconfiguration, cpu_reboot() does the fol‐
     lowing:

	   1.	Sets the boothowto system variable (see boothowto(9)) from the
		howto argument.

	   2.	If this is the first invocation of cpu_reboot() and the
		RB_NOSYNC flag is not set in howto, syncs and unmounts the
		system disks by calling vfs_shutdown(9) and sets the time of
		day clock by calling resettodr(9).

	   3.	Disables interrupts.

	   4.	If rebooting after a crash (i.e., if RB_DUMP is set in howto,
		but RB_HALT is not), saves a system crash dump.

	   5.	Runs any shutdown hooks by calling pmf_system_shutdown(9).

	   6.	Prints a message indicating that the system is about to be
		halted or rebooted.

	   7.	If RB_HALT is set in howto, halts the system.  Otherwise,
		reboots the system.

     If the system has not finished autoconfiguration, cpu_reboot() runs any
     shutdown hooks by calling pmf_system_shutdown(9), prints a message, and
     halts the system.

     If RB_STRING is set in howto, then the parameter bootstr is passed to the
     system boot loader on some ports.

SEE ALSO
     boothowto(9), dumpsys(9), pmf_system_shutdown(9), resettodr(9),
     vfs_shutdown(9)

BSD			       February 11, 2010			   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net