boottime man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

TIME(9)			 BSD Kernel Developer's Manual		       TIME(9)

NAME
     boottime, time_second — system time variables

SYNOPSIS
     #include <sys/time.h>

     extern struct timeval boottime;
     extern time_t time_second;

DESCRIPTION
     The boottime variable holds the system boot time.	The time_second vari‐
     able is the system's “wall time” clock to the second.

     The microtime(9), getmicrotime(9), nanotime(9), and getnanotime(9) func‐
     tions can be used to get the current time in an atomic manner.  Simi‐
     larly, the microuptime(9), getmicrouptime(9), nanouptime(9), and
     getnanouptime(9) functions can be used to get the time elapsed since boot
     in an atomic manner.  The boottime variable may be read and written with‐
     out special precautions.

SEE ALSO
     clock_settime(2), ntp_adjtime(2), settimeofday(2), inittodr(9),
     microtime(9), microuptime(9)

BSD				 April 9, 2008				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net