bcmp man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

BCMP(9)			 BSD Kernel Developer's Manual		       BCMP(9)

NAME
     bcmp — compare byte string

SYNOPSIS
     #include <sys/systm.h>

     int
     bcmp(const void *b1, const void *b2, size_t len);

DESCRIPTION
     The bcmp() interface is obsolete.	Do not add new code using it.  It will
     soon be purged.  Use memcmp(9) instead.  (The bcmp() function is now a
     macro for memcmp(9).)

     The bcmp() function compares byte string b1 against byte string b2,
     returning zero if they are identical, non-zero otherwise.	Both strings
     are assumed to be len bytes long.	Zero-length strings are always identi‐
     cal.

     The strings may overlap.

SEE ALSO
     memcmp(9)

BSD				 July 7, 2001				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net