vlan man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

VLAN(4)			    BSD Programmer's Manual		       VLAN(4)

NAME
     vlan - Virtual LAN (VLAN)

SYNOPSIS
     #include <sys/types.h>
     #include <sys/ioctl.h>
     #include <net/if.h>
     #include <netinet/if_ether.h>
     #include <net/if_vlan.h>

     pseudo-device vlan count

DESCRIPTION
     The Virtual LAN Interface provides a method for trunking multiple broad-
     cast domains through one physical interface.  Currently only 802.1q vlan
     tagging is supported.

     To support vlans, the number of virtual interfaces should be provided us-
     ing the vlan pseudo-device specification.	The number of Virtual LAN in-
     terfaces may be increased by adjusting count at kernel config time, modi-
     fying the nvlan variable in the system with bpatch(1) before booting, or
     by modifying the net.link_layer.generic.vlan.numif variable with
     sysctl(1).

     The VLAN names are composed from the prefix ``vlan'' and a decimal inter-
     face number; for example ``vlan0''.

   802.1
     Currently only 8021.Q encapsulation on Ethernet interfaces is supported.
     User priorities are not generated on output and are ignored on input.

IOCTL OPERATIONS
     The SIOCSETVLAN ioctl is used to connect a vlan interface to a physical
     interface.

     The layout of the struct vlanreq is:

     struct  vlanreq {
	     char    vlr_name[IFNAMSIZ];
	     char    vlr_parent[IFNAMSIZ];
	     union {
		     u_int16_t vlru_8021q_vid;	     /* Vlan ID */
	     } vlr_u;
     };
     #define vlr_8021q_vid   vlr_u.vlru_8021q_vid
     To disconnect the parent interface, use SIOCSETVLAN with a zero-length
     vlanreq.vlr_parent name.

     The SIOCGETVLAN ioctl is used read out the current vlan settings.

SEE ALSO
     sysctl(1),	 ioctl(2),  socket(2),	intro(4),  ifconfig(8),

STANDARDS
     IEEE Std 802.1Q-1998 (``Virtual Bridged Local Area networks'')

BUGS
     The vlan facility is currently of experimental nature and is likely to
     change in future releases.

     Not all Ethernet interfaces properly support the 1522 byte frames re-
     quired to send and received full-sized packets with 802.1Q encapsulation.
     Check the man pages for the specific Ethernet interface for details.

     Packets that contain 802.1Q routing information (i.e. have the CFI bit
     set) are currently ignored.

     No dynamic configuration of 802.1 VLANs is supported.

 BSD/OS				 Dec 23, 1999				     2
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net