types man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

TYPES(5)		    BSD Programmer's Manual		      TYPES(5)

NAME
     types - system data types

SYNOPSIS
     #include <sys/types.h>

DESCRIPTION
     The file <sys/types.h> contains defined data types used throughout the
     system.

     /* Architecture dependent types. */
     typedef unsigned long	      clock_t;
     typedef unsigned int	       size_t;
     typedef int		      ssize_t;
     typedef long		       time_t;

     /* Virtual memory objects. */
     typedef unsigned long	  vm_offset_t;
     typedef unsigned long	    vm_size_t;

     /* The longest/most efficient integer register type. */
     typedef int32_t		     register_t;

     /* Architecture independent types. */

     /* Basic integral types of exactly the implied number of bits. */
     typedef __signed char		int8_t;
     typedef unsigned char	      u_int8_t;
     typedef short		       int16_t;
     typedef unsigned short	     u_int16_t;
     typedef int		       int32_t;
     typedef unsigned int	     u_int32_t;
     typedef long long		       int64_t;
     typedef unsigned long long	     u_int64_t;

     /* Basic integral types of at least the implied number of bits. */
     typedef __signed char		int8m_t;
     typedef unsigned char	      u_int8m_t;
     typedef short		       int16m_t;
     typedef unsigned short	     u_int16m_t;
     typedef int		       int32m_t;
     typedef unsigned int	     u_int32m_t;
     typedef long long		       int64m_t;
     typedef unsigned long long	     u_int64m_t;

     typedef unsigned long		 u_long;
     typedef unsigned int		  u_int;
     typedef unsigned short		u_short;
     typedef unsigned char		 u_char;
     typedef unsigned int		   uint;     /* Sys V compatibility */
     typedef unsigned short		 ushort;     /* Sys V compatibility */

     typedef u_int64_t		       u_quad_t;     /* quads */
     typedef int64_t			 quad_t;
     typedef quad_t *			qaddr_t;

     typedef char *			caddr_t;     /* core address */
     typedef long			daddr_t;     /* disk address */
     typedef unsigned long		  dev_t;     /* device number */
     typedef unsigned long		fixpt_t;     /* fixed point number */
     typedef unsigned int		  gid_t;     /* group id */
     typedef unsigned long		  ino_t;     /* inode number */
     typedef long			  key_t;     /* Sys V IPC key */
     typedef u_int16m_t			 mode_t;     /* permissions */
     typedef u_int16m_t			nlink_t;     /* link count */
     typedef quad_t			  off_t;     /* file offset */
     typedef int			  pid_t;     /* process id */
     typedef long			segsz_t;     /* segment size */
     typedef long			swblk_t;     /* swap offset */
     typedef unsigned int		  uid_t;     /* user id */

HISTORY
     A <sys/types.h> file appeared in Version 7 AT&T UNIX.

4th Berkeley Distribution	April 28, 1995				     2
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net