suibyte man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

STORE(9)		 BSD Kernel Developer's Manual		      STORE(9)

NAME
     store, subyte, suibyte, susword, suswintr, suword, suiword — store data
     to user-space

SYNOPSIS
     #include <sys/types.h>
     #include <sys/systm.h>

     int
     subyte(void *base, int c);

     int
     susword(void *base, short c);

     int
     suswintr(void *base, short c);

     int
     suword(void *base, long c);

DESCRIPTION
     The store functions are designed to copy small amounts of data to the
     user-space of the currently running process.

     The store routines provide the following functionality:

     subyte()	 Stores a byte of data to the user-space address base.

     susword()	 Stores a short word of data to the user-space address base.

     suswintr()	 Stores a short word of data to the user-space address base.
		 This function is safe to call during an interrupt context.

     suword()	 Stores a word of data to the user-space address base.

RETURN VALUES
     The store functions return 0 on success or -1 on failure.

SEE ALSO
     copy(9), fetch(9)

BSD				January 7, 1996				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net