store man page on OpenDarwin

Man page or keyword search:  
man Server   3202 pages
apropos Keyword Search (all sections)
Output format
OpenDarwin logo
[printable version]

STORE(9)		 BSD Kernel Developer's Manual		      STORE(9)

NAME
     store, subyte, susword, suswintr, suword — store data to user-space

SYNOPSIS
     #include <sys/types.h>
     #include <sys/time.h>
     #include <sys/systm.h>
     #include <sys/resourcevar.h>

     int
     subyte(void *base, int byte);

     int
     susword(void *base, int word);

     int
     suswintr(void *base, int word);

     int
     suword(void *base, long word);

DESCRIPTION
     The store functions are designed to copy small amounts of data to user-
     space.

     The store routines provide the following functionality:

     subyte()	 Stores a byte of data to the user-space address base.

     susword()	 Stores a short word of data to the user-space address base.

     suswintr()	 Stores a short word of data to the user-space address base.
		 This function is safe to call during an interrupt context.

     suword()	 Stores a word of data to the user-space address base.

RETURN VALUES
     The store functions return 0 on success or -1 on failure.

SEE ALSO
     copy(9), fetch(9)

BSD				January 7, 1996				   BSD
[top]

List of man pages available for OpenDarwin

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net