spp man page on MirBSD

Man page or keyword search:  
man Server   6113 pages
apropos Keyword Search (all sections)
Output format
MirBSD logo
[printable version]

SPP(4)			   BSD Programmer's Manual			SPP(4)

NAME
     spp - Xerox Sequenced Packet Protocol

SYNOPSIS
     #include <sys/socket.h>
     #include <netns/ns.h>
     #include <netns/sp.h>

     int
     socket(AF_NS, SOCK_STREAM, 0);

     int
     socket(AF_NS, SOCK_SEQPACKET, 0);

DESCRIPTION
     The SPP protocol provides a reliable, flow-controlled, two-way transmis-
     sion of data. It is a byte-stream protocol used to support the
     SOCK_STREAM abstraction. SPP uses the standard NS(tm) address formats.

     Sockets utilizing the SPP protocol are either "active" or "passive". Ac-
     tive sockets initiate connections to passive sockets. By default SPP
     sockets are created active; to create a passive socket the listen(2) sys-
     tem call must be used after binding the socket with the bind(2) system
     call. Only passive sockets may use the accept(2) call to accept incoming
     connections. Only active sockets may use the connect(2) call to initiate
     connections.

     Passive sockets may "underspecify" their location to match incoming con-
     nection requests from multiple networks. This technique, termed "wildcard
     addressing", allows a single server to provide service to clients on mul-
     tiple networks. To create a socket which listens on all networks, the NS
     address of all zeroes must be bound. The SPP port may still be specified
     at this time; if the port is not specified the system will assign one.
     Once a connection has been established the socket's address is fixed by
     the peer entity's location. The address assigned to the socket is the ad-
     dress associated with the network interface through which packets are be-
     ing transmitted and received. Normally this address corresponds to the
     peer entity's network.

     If the SOCK_SEQPACKET socket type is specified, each packet received has
     the actual 12 byte sequenced packet header left for the user to inspect:

	   struct sphdr {
		   u_char	   sp_cc;  /* connection control */
	   #define SP_EM   0x10		   /* end of message */
		   u_char	   sp_dt;  /* datastream type */
		   u_short	   sp_sid;
		   u_short	   sp_did;
		   u_short	   sp_seq;
		   u_short	   sp_ack;
		   u_short	   sp_alo;
	   };

     This facilitates the implementation of higher level Xerox protocols which
     make use of the data stream type field and the end of message bit. Con-
     versely, the user is required to supply a 12 byte header, the only part
     of which inspected is the data stream type and end of message fields.

     For either socket type, packets received with the Attention bit sent are
     interpreted as out of band data. Data sent with "send(..., ..., ...,
     MSG_OOB") cause the attention bit to be set.

DIAGNOSTICS
     A socket operation may fail with one of the following errors returned:
     [EISCONN]	      when trying to establish a connection on a socket which
		      already has one;

     [ENOBUFS]	      when the system runs out of memory for an internal data
		      structure;

     [ETIMEDOUT]      when a connection was dropped due to excessive re-
		      transmissions;

     [ECONNRESET]     when the remote peer forces the connection to be closed;

     [ECONNREFUSED]   when the remote peer actively refuses connection estab-
		      lishment (usually because no process is listening to the
		      port);

     [EADDRINUSE]     when an attempt is made to create a socket with a port
		      which has already been allocated;

     [EADDRNOTAVAIL]  when an attempt is made to create a socket with a net-
		      work address for which no network interface exists.

SOCKET OPTIONS
     SO_DEFAULT_HEADERS	 when set, this determines the data stream type and
			 whether the end of message bit is to be set on every
			 ensuing packet.

     SO_MTU		 This specifies the maximum amount of user data in a
			 single packet. The default is 576 bytes -
			 sizeof(struct spidp). This quantity affects windowing
			 - increasing it without increasing the amount of
			 buffering in the socket will lower the number of un-
			 read packets accepted. Anything larger than the de-
			 fault will not be forwarded by a bona fide XEROX pro-
			 duct internetwork router. The data argument for the
			 setsockopt call must be an unsigned short.

SEE ALSO
     netintro(4), ns(4)

HISTORY
     The spp protocol appeared in 4.3BSD.

BUGS
     There should be some way to reflect record boundaries in a stream. For
     stream mode, there should be an option to get the data stream type of the
     record the user process is about to receive.

MirOS BSD #10-current		April 19, 1994				     1
[top]

List of man pages available for MirBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net