splraiseipl man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

SPLRAISEIPL(9)		 BSD Kernel Developer's Manual		SPLRAISEIPL(9)

NAME
     splraiseipl — raise the system priority level

SYNOPSIS
     #include <sys/param.h>

     int
     splraiseipl(ipl_cookie_t icookie);

DESCRIPTION
     splraiseipl() raises the system priority level to the level specified by
     icookie.  icookie should be a value returned by makeiplcookie().

     In general, device drivers should not make use of this interface.	To
     ensure correct synchronization, device drivers should use the condvar(9),
     mutex(9), and rwlock(9) interfaces.

     See the spl(9) manual page for a description of interrupt priority lev‐
     els.

RETURN VALUES
     splraiseipl() returns saved priority level which can be used for splx().

EXAMPLES
     The following two lines are functional equivalents.

	     s = splraiseipl(makeiplcookie(IPL_VM));

	     s = splvm();

     Because makeiplcookie() can be slow and is not expected to be used in a
     perfomance critical path, it's better to do it beforehand.

	     initialization_code(ipl_t ipl)
	     {

		     ourcookie = makeiplcookie(ipl);
	     }

	     performance_critical_code()
	     {
		     int s;

		     s = splraiseipl(ourcookie);
		     do_something();
		     splx(s);
	     }

SEE ALSO
     condvar(9), makeiplcookie(9), mutex(9), rwlock(9), spl(9)

BSD			       February 11, 2007			   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net