securelevel_ge man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

SECURELEVEL_GT(9)	 BSD Kernel Developer's Manual	     SECURELEVEL_GT(9)

NAME
     securelevel_gt, securelevel_ge — test active securelevel

SYNOPSIS
     #include <sys/types.h>
     #include <sys/proc.h>

     int
     securelevel_gt(struct ucred *cr, int level);

     int
     securelevel_ge(struct ucred *cr, int level);

DESCRIPTION
     These functions test the active security level against the given level.
     If the calling credential cr was imprisoned by the jail(2) system call,
     and has a different security level set than the host environment, the
     security level with the highest value is used.

     The securelevel_gt() function will evaluate whether or not the active
     security level is greater than the supplied level.

     The securelevel_ge() function will evaluate whether or not the active
     security level is greater than or equal to the supplied level.

RETURN VALUES
     These functions return EPERM if condition evaluated to true, and 0 other‐
     wise.

SEE ALSO
     securelevel(7)

BSD				 June 2, 2007				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net