scanc man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

SCANC(9)		 BSD Kernel Developer's Manual		      SCANC(9)

NAME
     scanc — use byte string as lookup table index

SYNOPSIS
     #include <lib/libkern/libkern.h>

     int
     scanc(size_t size, const u_char *cp, const u_char table[], int mask);

DESCRIPTION
     The scanc() function scans the byte string cp, whose length is size.  A
     character in the string is used as an index in the 256-byte table.	 If a
     bitwise-AND of the byte from the table and mask isn't zero or the string
     is exhausted, the scan stops.

RETURN VALUES
     The scanc() function returns the number of characters skipped.

HISTORY
     The scanc() function emulates a VAX instruction with the same name.

BSD			       November 1, 2011				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net