RWHOD(8) BSD System Manager's Manual RWHOD(8)NAMErwhod - system status server
SYNOPSISrwhod
rwhod -m
rwhod-M ttl
DESCRIPTION
The rwhod server maintains the database used by the rwho(1) and rup-
time(1) programs. Its operation is predicated on the ability to
broadcast or multicast messages on a network.
The rwhod program operates as both a producer and consumer of status in-
formation. As a producer of information it periodically queries the
state of the system and constructs status messages which are broadcast or
multicast on a network. As a consumer of information, it listens for
other rwhod servers' status messages, validating them, then recording
them in a collection of files located in the directory /var/rwho.
The -m and -M flags configure rwhod to use multicast rather than broad-
cast. Under -m, rwhod sends its multicast message to all multicast-capa-
ble interfaces (those with IFF_MULTICAST set in their flags; see
ifconfig(8)). In this case the time-to-live is fixed at 1, preventing
the multicast from being forwarded beyond any directly-connected subnets.
With -M, rwhod sends its multicast message with the given ttl as its time
to live, but to the ``whod'' group (224.0.1.3) rather than individually
to each interface. This is intended to be used with a multicast router
which will distribute the message to members of the multicast group.
In any mode, broadcast or multicast, rwhod will accept all forms of re-
ports. This means that if broadcast and multicast rwhod servers are com-
bined on one network, the multicast-capable systems will see everyone,
while the broadcast-only machines will see only each other.
The server transmits and receives messages at the port indicated in the
``rwho'' service specification; see services(5). The messages sent and
received are of the form:
struct outmp {
char out_line[8]; /* tty name */
char out_name[8]; /* user id */
long out_time; /* time on */
};
struct whod {
char wd_vers;
char wd_type;
char wd_fill[2];
int wd_sendtime;
int wd_recvtime;
char wd_hostname[32];
int wd_loadav[3];
int wd_boottime;
struct whoent {
struct outmp we_utmp;
int we_idle;
} wd_we[1024 / sizeof (struct whoent)];
};
All fields are converted to network byte order prior to transmission.
The load averages are as calculated by the w(1) program, and represent
load averages over the 5, 10, and 15 minute intervals prior to a server's
transmission; they are multiplied by 100 for representation in an inte-
ger. The host name included is that returned by the gethostname(2) sys-
tem call, with any trailing domain name omitted. The array at the end of
the message contains information about the users logged in to the sending
machine. This information includes the contents of the utmp(5) entry for
each non-idle terminal line and a value indicating the time in seconds
since a character was last received on the terminal line.
Messages received by the rwho server are discarded unless they originated
at an rwho server's port. In addition, if the host's name, as specified
in the message, contains any unprintable ASCII characters, the message is
discarded. Valid messages received by rwhod are placed in files named
whod.hostname in the directory /var/rwho. These files contain only the
most recent message, in the format described above.
Status messages are generated approximately once every 3 minutes.
SEE ALSOmrouted(8), rwho(1), ruptime(1)BUGS
Status information should be sent only upon request rather than continu-
ously. People often interpret the server dying or network communication
failures as a machine going down.
HISTORY
The rwhod command appeared in 4.2BSD. The multicast additions are from
Stanford University.
4.2 Berkeley Distribution December 11, 1993 2