rt_timer_queue_change man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

RT_TIMER(9)		 BSD Kernel Developer's Manual		   RT_TIMER(9)

NAME
     rt_timer, rt_timer_add, rt_timer_queue_create, rt_timer_queue_change,
     rt_timer_queue_destroy, rt_timer_remove_all — route callout functions

SYNOPSIS
     #include <net/route.h>

     struct rttimer_queue *
     rt_timer_queue_create(time_t timeout);

     void
     rt_timer_queue_change(struct rttimer_queue *q, time_t timeout);

     void
     rt_timer_queue_destroy(struct rttimer_queue *q, int destroy);

     int
     rt_timer_add(struct rtentry *rt,
	 void(*f)(struct rtentry *, struct rttimer *),
	 struct rttimer_queue *q);

     void
     rt_timer_remove_all(struct rtentry *rt);

DESCRIPTION
     The rt_timer functions provide a generic route callout functionality.
     They allow a function to be called for a route at any time.  This was
     originally intended to be used to remove routes added by path MTU discov‐
     ery code.

     For maximum efficiency, a separate queue should be defined for each time‐
     out period.  For example, one queue should be created for the 10 minute
     path MTU discovery timeouts, another for 20 minute ARP timeouts after 20
     minutes, and so on.  This permits extremely fast queue manipulations so
     that the timeout functions remain scalable, even in the face of thousands
     of route manipulations per minute.

     It is possible to create only a single timeout queue for all possible
     timeout values, but doing so is not scalable as queue manipulations
     become quite expensive if the timeout deltas are not roughly constant.

     The rt_timer interface provides the following functions:

     rt_timer_queue_create(time_t timeout)
	      This function creates a new timer queue with the specified time‐
	      out period timeout, expressed in seconds.

     rt_timer_queue_change(rttimer_queue *q, time_t timeout)
	      This function modifies the timeout period for a timer queue.
	      Any value, including 0, is valid.	 The next time the timer
	      queue's timeout expires (based on the previous timeout value),
	      all entries which are valid to execute based on the new timeout
	      will be executed, and the new timeout period scheduled.

     rt_timer_queue_destroy(rttimer_queue *q, int destroy)
	      This function destroys a timeout queue.  All entries are
	      removed, and if the destroy argument is non-zero, the timeout
	      action is performed for each entry.

     rt_timer_add(struct rtentry *rt, void(*f)(struct rtentry *, struct
	      rttimer *), struct rttimer_queue *q)
	      This function adds an entry to a timeout queue.  The function f
	      will be called after the timeout period for queue q has elapsed.
	      If f is NULL the route will be deleted when the timeout expires.

     rt_timer_remove_all(struct rtentry *rt)
	      This function removes all references to the given route from the
	      rt_timer subsystem.  This is used when a route is deleted to
	      ensure that no dangling references remain.

SEE ALSO
     netstat(1), arp(9)

HISTORY
     The rt_timer interface appeared in NetBSD 1.4.

AUTHORS
     This interface is roughly based on (but, alas, not compatible with) one
     designed by David Borman of BSDI.	This implementation is by Kevin Lahey
     of the Numerical Aerospace Simulation Facility, NASA Ames Research Cen‐
     ter.

CODE REFERENCES
     The rt_timer interface is implemented in sys/net/route.h and
     sys/net/route.c.

BSD				April 23, 1998				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net