resource_string_value man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

RESOURCE_INT_VALUE(9)	 BSD Kernel Developer's Manual	 RESOURCE_INT_VALUE(9)

NAME
     resource_int_value, resource_long_value, resource_string_value — get a
     value from the hints mechanism

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     resource_int_value(const char *name, int unit, const char *resname,
	 int *result);

     int
     resource_long_value(const char *name, int unit, const char *resname,
	 long *result);

     int
     resource_string_value(const char *name, int unit, const char *resname,
	 const char **result);

DESCRIPTION
     These functions fetch a value from the “hints” mechanism.

     The functions take the following arguments:

     name     The name of the device to get the resource value from.

     unit     The unit number of the device.  -1 is special and is used for
	      wildcard entries.

     resname  The resource name.

     result   A pointer to memory in which to store the resource value.

RETURN VALUES
     If successful, the functions return 0.  Otherwise, a non-zero error code
     is returned.

ERRORS
     The functions will fail if:

     [ENOENT]		The resource could not be found.

     [EFTYPE]		Inappropriate resource type.

SEE ALSO
     device(9), driver(9)

AUTHORS
     This manual page was written by Warner Losh ⟨imp@FreeBSD.org⟩.

BSD				 March 1, 2001				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net