REBOOT(8) BSD System Manager's Manual REBOOT(8)NAME
reboot, halt — stopping and restarting the system
The halt and reboot utilities flush the file system cache to disk, send
all running processes a SIGTERM (and subsequently a SIGKILL) and, respec‐
tively, halt or restart the system. The action is logged, including
entering a shutdown record into the login accounting file.
The options are as follows:
-n If the -n option is specified, the file system cache is not
flushed. This option should probably not be used.
-q If the -q option is specified, the system is halted or restarted
quickly and ungracefully, and only the flushing of the file sys‐
tem cache is performed. This option should probably not be used.
Normally, the shutdown(8) utility is used when the system needs to be
halted or restarted, giving users advance warning of their impending
SEE ALSOsync(1), utmp(5), boot(8), shutdown(8)HISTORY
A reboot command appeared in Version 6 AT&T UNIX.
BSD June 9, 1993 BSD