putiobuf man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

GETIOBUF(9)		 BSD Kernel Developer's Manual		   GETIOBUF(9)

NAME
     getiobuf, putiobuf — I/O descriptor allocation interface

SYNOPSIS
     #include <sys/buf.h>

     struct buf *
     getiobuf(struct vnode *vp, bool waitok);

     void
     putiobuf(struct buf *bp);

DESCRIPTION
     getiobuf() allocates a buf structure.

     vp	     The vnode to which the allocated buffer will be associated.  This
	     can be NULL.

     waitok  If true, getiobuf can sleep until enough memory is available.
	     Otherwise, it returns NULL immediately if not enough memory is
	     available.

     Note that the allocated buffer doesn't belong to the buffer cache.	 To
     free it, putiobuf() should be used.  brelse() should not be used on it.

     putiobuf() frees bp, which should be a buffer allocated with getiobuf().

SEE ALSO
     buffercache(9), intro(9)

BSD				  May 6, 2008				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net