proc_find man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

PROC_FIND(9)		 BSD Kernel Developer's Manual		  PROC_FIND(9)

NAME
     proc_find, pgrp_find — find process or process group

SYNOPSIS
     #include <sys/proc.h>

     struct proc *
     proc_find(pid_t pid);

     struct pgrp *
     pgrp_find(pid_t pgid);

     extern kmutex_t *proc_lock;

DESCRIPTION
     The proc_find() and pgrp_find() functions retrieve process and process
     group structures from process ID pid and process group ID pgid.  Both
     functions must be called by holding a mutex(9) on proc_lock.

RETURN VALUES
     Upon successful completion, the described functions return a pointer to
     either struct proc or struct pgrp.	 Otherwise, if the requested ID was
     not found, NULL is returned.

SEE ALSO
     curproc(9)

BSD				 July 1, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net