pmap_zero_idle man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

PMAP_ZERO(9)		 BSD Kernel Developer's Manual		  PMAP_ZERO(9)

NAME
     pmap_zero_page, pmap_zero_area, pmap_zero_idle — zero-fill a page using
     machine-dependent optimizations

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/pmap.h>

     void
     pmap_zero_page(vm_page_t m);

     void
     pmap_zero_page_area(vm_page_t m, int off, int size);

     void
     pmap_zero_page_idle(vm_page_t m);

DESCRIPTION
     The pmap_zero_page() function zero-fills an entire page using machine-
     dependent optimizations.  The pmap_zero_page_area() function is used to
     zero-fill an area of a page.  The range specified must not cross a page
     boundary; it must be contained entirely within a single page.

     The pmap_zero_page_idle() interface is used by the vm_pagezero process.
     The system-wide Giant lock should not be required to be held in order to
     call this interface.

IMPLEMENTATION NOTES
     This function is required to be implemented for each architecture sup‐
     ported by FreeBSD.

SEE ALSO
     bzero(3), pmap(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 21, 2003				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net