pmap_protect man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

PMAP_PROTECT(9)		 BSD Kernel Developer's Manual	       PMAP_PROTECT(9)

NAME
     pmap_page_protect, pmap_protect — set physical page protection

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/pmap.h>

     void
     pmap_page_protect(vm_page_t m, vm_prot_t prot);

     void
     pmap_protect(pmap_t pmap, vm_offset_t sva, vm_offset_t eva,
	 vm_prot_t pr);

DESCRIPTION
     The pmap_page_protect() function lowers the physical page permissions to
     prot for all mappings of a given page m.

     The pmap_protect() function sets the physical page permissions to prot
     for all physical pages in the physical map pmap in the virtual address
     range between sva and eva.

SEE ALSO
     pmap(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 21, 2003				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net