pmap_object_init_pt man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

PMAP_OBJECT_INIT_PT(9)	 BSD Kernel Developer's Manual	PMAP_OBJECT_INIT_PT(9)

NAME
     pmap_object_init_pt — initialize page tables for a VM object

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/pmap.h>

     void
     pmap_object_init_pt(pmap_t pmap, vm_offset_t addr, vm_object_t object,
	 vm_pindex_t pindex, vm_size_t size, int limit);

DESCRIPTION
     The pmap_object_init_pt() function preloads the page table entries into
     the specified physical map pmap, for the given object at the virtual
     address addr, for size bytes, beginning at the page index pindex within
     the object.  The map bits limit are heeded when creating the mapping.

IMPLEMENTATION NOTES
     This function is not strictly required by an architecture's pmap(9)
     implementation, but it does provide performance benefits if implemented.

     It is intended to eliminate the blast of soft faults on process startup,
     and immediately following a call to mmap(2).

SEE ALSO
     pmap(9), vm_map(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 21, 2003				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net