pmap_map man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

PMAP_MAP(9)		 BSD Kernel Developer's Manual		   PMAP_MAP(9)

NAME
     pmap_map — map a physical memory range into kernel virtual address (KVA)
     space

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/pmap.h>

     vm_offset_t
     pmap_map(vm_offset_t *virt, vm_paddr_t start, vm_paddr_t end, int prot);

DESCRIPTION
     The pmap_map() function maps a range of physical addresses into kernel
     virtual address (KVA) space, from start to end, with protection bits
     prot.

     The value passed in *virt is treated as a hint for the virtual address of
     the beginning of the mapping.

IMPLEMENTATION NOTES
     The prot argument is currently ignored by machine-dependent implementa‐
     tions.

     Architectures which can support a direct mapped physical to virtual
     region can return the appropriate address within that region, leaving
     *virt unchanged.

RETURN VALUES
     The pmap_map() function returns the virtual address of the beginning of
     the mapping, if the mapping was successfully made; *virt will also be
     updated with the first usable address after the mapped region.

     If the function is unsuccessful, NULL is returned.

SEE ALSO
     pmap(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 21, 2003				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net