pmap_is_modified man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

PMAP_IS_MODIFIED(9)	 BSD Kernel Developer's Manual	   PMAP_IS_MODIFIED(9)

NAME
     pmap_is_modified, pmap_ts_modified — return information about physical
     pages

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/pmap.h>

     boolean_t
     pmap_is_modified(vm_page_t m);

     int
     pmap_ts_referenced(vm_page_t m);

DESCRIPTION
     The pmap_is_modified() and pmap_ts_referenced() functions return informa‐
     tion about physical pages.

RETURN VALUES
     The pmap_is_modified() function returns the status of the “page modified”
     bit for the physical page m.

     The pmap_ts_referenced() function returns a count of reference bits for a
     page m, clearing those bits.  It is not necessary for every reference bit
     to be cleared, but it is necessary that 0 only be returned when there are
     no remaining reference bits set on the page.

SEE ALSO
     pmap(9), pmap_clear_modify(9), pmap_clear_reference(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 21, 2003				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net