pmap_change_wiring man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

PMAP_CHANGE_WIRING(9)	 BSD Kernel Developer's Manual	 PMAP_CHANGE_WIRING(9)

NAME
     pmap_change_wiring — change physical wiring for a map or virtual address
     pair

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/pmap.h>

     void
     pmap_change_wiring(pmap_t pmap, vm_offset_t va, boolean_t wired);

DESCRIPTION
     The pmap_change_wiring() function changes the wiring attribute for the
     page at virtual address va in the physical map pmap.  A wired page gets
     its name from being “wired” into the system page tables so that it will
     not be paged out.

     The mapping must already exist in the pmap.  If wired is TRUE, the map's
     wired page count will be incremented; if FALSE, it will be decremented.

     It is typically called by the vm_fault_unwire() function.

SEE ALSO
     pmap(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 21, 2003				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net