pgfind man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

PGFIND(9)		 BSD Kernel Developer's Manual		     PGFIND(9)

NAME
     pgfind — locate a process group by number

SYNOPSIS
     #include <sys/param.h>
     #include <sys/proc.h>

     struct pgrp *
     pgfind(pid_t pgid);

DESCRIPTION
     The pgfind() function takes a pgid as its argument and returns a pointer
     to the pgrp structure whose pg_id is specified in the argument.

     pgfind() locks the pgrp structure that is returned.

RETURN VALUES
     The pgfind() function returns NULL on failure or a pointer to a pgrp
     structure on successful completion.

SEE ALSO
     pfind(9)

AUTHORS
     This manual page was written by Evan Sarmiento ⟨kaworu@sektor7.ath.cx⟩.

BSD				August 8, 2001				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net