pci_config_get16 man page on SmartOS

Printed from http://www.polarhome.com/service/man/?qf=pci_config_get16&af=0&tf=2&of=SmartOS

PCI_CONFIG_GET8(9F)					   PCI_CONFIG_GET8(9F)

NAME
       pci_config_get8,	 pci_config_get16, pci_config_get32, pci_config_get64,
       pci_config_put8, pci_config_put16, pci_config_put32,  pci_config_put64,
       pci_config_getb,	 pci_config_getl,  pci_config_getll,  pci_config_getw,
       pci_config_putb, pci_config_putl, pci_config_putll,  pci_config_putw  -
       read  or	 write single datum of various sizes to the PCI Local Bus Con‐
       figuration space

SYNOPSIS
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       uint8_t pci_config_get8(ddi_acc_handle_t handle, off_t offset);

       uint16_t pci_config_get16(ddi_acc_handle_t handle, off_t offset);

       uint32_t pci_config_get32(ddi_acc_handle_t handle, off_t offset);

       uint64_t pci_config_get64(ddi_acc_handle_t handle, off_t offset);

       void pci_config_put8(ddi_acc_handle_t handle, off_t offset,
	    uint8_t value);

       void pci_config_put16(ddi_acc_handle_t handle, off_t offset,
	    uint16_t value);

       void pci_config_put32(ddi_acc_handle_t handle, off_t offset,
	    uint32_t value);

       void pci_config_put64(ddi_acc_handle_t handle, off_t offset,
	    uint64_t value);

INTERFACE LEVEL
       Solaris DDI specific (Solaris  DDI).  The  pci_config_getb(),  pci_con‐
       fig_getl(),  pci_config_getll(),	 pci_config_getw(), pci_config_putb(),
       pci_config_putl(), pci_config_putll(), and pci_config_putw()  functions
       are   obsolete.	 The   pci_config_get8()  function  replaces  pci_con‐
       fig_getb(). The pci_config_get32() function replaces pci_config_getl().
       The   pci_config_get64()	  function  replaces  pci_config_getll().  The
       pci_config_get16() function replaces  pci_config_getw().	 The  pci_con‐
       fig_put8()  function replaces pci_config_putb(). The pci_config_put32()
       function replaces pci_config_putl().  The  pci_config_put64()  function
       replaces	 pci_config_putll().  The pci_config_put16() function replaces
       pci_config_putw().

PARAMETERS
       handle
		 The data access handle returned from pci_config_setup(9F).

       offset
		 Byte offset from  the	beginning  of  the  PCI	 Configuration
		 space.

       value
		 Output data.

DESCRIPTION
       These routines read or write a single datum of various sizes from or to
       the PCI Local Bus Configuration space. The pci_config_get8(),  pci_con‐
       fig_get16(),  pci_config_get32(), and pci_config_get64() functions read
       8 bits, 16 bits, 32 bits,  and  64  bits	 of  data,  respectively.  The
       pci_config_put8(), pci_config_put16(), pci_config_put32(), and pci_con‐
       fig_put64() functions write 8 bits, 16 bits, 32 bits, and  64  bits  of
       data, respectively. The offset argument must be a multiple of the datum
       size.

       Since th	 PCI Local Bus Configuration space is  represented  in	little
       endian  data  format,  these  functions	translate  the data from or to
       native host format to or from little endian format.

       pci_config_setup(9F) must be called before invoking these functions.

RETURN VALUES
       pci_config_get8(), pci_config_get16(), pci_config_get32(), and pci_con‐
       fig_get64() return the value read from the  PCI Local Bus Configuration
       space.

CONTEXT
       These routines can be called from user, kernel, or interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬────────────────────────────┐
       │  ATTRIBUTE TYPE    │	   ATTRIBUTE VALUE	 │
       ├────────────────────┼────────────────────────────┤
       │Interface Stability │ pci_config_getb(),	 │
       │		    │ pci_config_getl(),	 │
       │		    │ pci_config_getll(),	 │
       │		    │ pci_config_getw(),	 │
       │		    │ pci_config_putb(),	 │
       │		    │ pci_config_putl(),	 │
       │		    │ pci_config_putll(),	 │
       │		    │ pci_config_putw()	     are │
       │		    │ Obsolete		pci_con‐ │
       │		    │ fig_get8(),	pci_con‐ │
       │		    │ fig_get16(),	pci_con‐ │
       │		    │ fig_get32(),	pci_con‐ │
       │		    │ fig_get64(),	pci_con‐ │
       │		    │ fig_put8(),	pci_con‐ │
       │		    │ fig_put16(),	pci_con‐ │
       │		    │ fig_put32(),	pci_con‐ │
       │		    │ fig_put64() are Committed	 │
       └────────────────────┴────────────────────────────┘

SEE ALSO
       attributes(5), pci_config_setup(9F), pci_config_teardown(9F)

				  Nov 1, 2005		   PCI_CONFIG_GET8(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net