nvlist_lookup_nvpair man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NVLIST_LOOKUP_NVPAIR(9F)			      NVLIST_LOOKUP_NVPAIR(9F)

NAME
       nvlist_lookup_nvpair, nvlist_exists - lookup named pairs

SYNOPSIS
       #include <libnvpair.h>

       int nvlist_lookup_nvpair(nvlist_t *nvl, const char *name,
	    nvpair_t **nvp);

       boolean_t nvlist_exists(nvlist_t *nvl, const char *name);

DESCRIPTION
       The  nvlist_lookup_nvpair() function returns the nvpair with the match‐
       ing name, regardless of type. It is valid only for lists allocated with
       NV_UNIQUE_NAME. See nvlist_alloc(9F).

       The  nvlist_exists() function returns success if any nvpair exists with
       the given name. It is valid for all types of lists.

RETURN VALUES
       The nvlist_lookup_nvpair() function returns 0 on success and  an	 error
       value on failure.

       The nvlist_exists() function returns B_TRUE if an nvpair with the given
       name exists and B_FALSE otherwise.

ERRORS
       The nvlist_lookup_nvpair() function will fail if:

       EINVAL
		  There is an invalid argument.

       ENOENT
		  No matching name-value pair is found.

       ENOTSUP
		  The list was not allocated with NV_UNIQUE_NAME.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       nvlist_lookup_nvpair(3NVPAIR), nvlist_alloc(9F), attributes(5)

				 Oct 24, 2007	      NVLIST_LOOKUP_NVPAIR(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net