nullop man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

NULLOP(9)		 BSD Kernel Developer's Manual		     NULLOP(9)

NAME
     nullop — dummy functions

SYNOPSIS
     #include <sys/systm.h>

     int
     nullop(void *v);

     void
     voidop(void);

     int
     enodev(void);

     int
     enxio(void);

     int
     enoioctl(void);

     int
     enosys(void);

     int
     eopnotsupp(void);

DESCRIPTION
     The nullop() function provides a generic “null operation”.	 It always
     returns the value 0.  The voidop() function takes no arguments and does
     nothing.

     The enodev(), enxio(), enoioctl(), enosys(), and eopnotsupp() functions
     always fail, returning ENODEV, ENXIO, ENOTTY, ENOSYS, and EOPNOTSUPP,
     respectively.

EXAMPLES
     The following example demonstrates a case where nullop() may be useful:

	   uint64_t xc;

	   ...

	   xc = xc_broadcast(0, (xcfunc_t)nullop, NULL, NULL);
	   xc_wait(xc);

BSD				 July 25, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net