ns man page on BSDOS

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDOS logo
[printable version]

NS(4)			    BSD Programmer's Manual			 NS(4)

NAME
     ns - Xerox Network Systems(tm) protocol family

SYNOPSIS
     options NS
     options NSIP
     pseudo-device ns

DESCRIPTION
     The NS protocol family is a collection of protocols layered atop the
     Internet Datagram Protocol (IDP) transport layer, and using the Xerox NS
     address formats.  The NS family provides protocol support for the
     SOCK_STREAM, SOCK_DGRAM, SOCK_SEQPACKET, and SOCK_RAW socket types; the
     SOCK_RAW interface is a debugging tool, allowing you to trace all packets
     entering, (or with toggling kernel variable, additionally leaving) the
     local host.

ADDRESSING
     NS addresses are 12 byte quantities, consisting of a 4 byte Network num-
     ber, a 6 byte Host number and a 2 byte port number, all stored in network
     standard format.  (on the VAX these are word and byte reversed; on the
     SUN they are not reversed).  The include file <netns/ns.h> defines the NS
     address as a structure containing unions (for quicker comparisons).

     Sockets in the Internet protocol family use the following addressing
     structure:

	   struct sockaddr_ns {
		   u_char	   sns_len;
		   u_char	   sns_family;
		   struct ns_addr  sns_addr;
		   char		   sns_zero[2];
	   };

     where an ns_addr is composed as follows:

	   union ns_host {
		   u_char	   c_host[6];
		   u_short	   s_host[3];
	   };

	   union ns_net {
		   u_char	   c_net[4];
		   u_short	   s_net[2];
	   };

	   struct ns_addr {
		   union ns_net	   x_net;
		   union ns_host   x_host;
		   u_short x_port;
	   };

     Sockets may be created with an address of all zeroes to effect
     ``wildcard'' matching on incoming messages.  The local port address spec-
     ified in a bind(2) call is restricted to be greater than NSPORT_RESERVED
     (=3000, in <netns/ns.h>) unless the creating process is running as the
     super-user, providing a space of protected port numbers.

PROTOCOLS
     The NS protocol family supported by the operating system is composed of
     the Internet Datagram Protocol (IDP) idp(4),  Error Protocol (available
     through IDP), and Sequenced Packet Protocol (SPP) spp(4).

     SPP is used to support the SOCK_STREAM and SOCK_SEQPACKET abstraction,
     while IDP is used to support the SOCK_DGRAM abstraction.  The Error pro-
     tocol is responded to by the kernel to handle and report errors in proto-
     col processing; it is, however, only accessible to user programs through
     heroic actions.

INTERFACES
     A program may discover interface addresses by use of the sysctl(3) or
     getifaddrs(3) functions.  Interfaces are configured by using the
     SIOCAIFADDR and SIOCDIFADDR ioctl(2) calls with the ns_aliasreq and ifreq
     structures Respectively.

SEE ALSO
     intro(3),	byteorder(3),  gethostbyname(3),  getifaddrs(3,) getnetent(3),
      getprotoent(3),  getservent(3),  ns(3),  sysctl(3),  netintro(4),
     route(4),	spp(4),	 idp(4),  nsip(4)

     Internet Transport Protocols, Xerox Corporation document XSIS, 028112.

     An Advanced 4.3 BSD Interprocess Communication Tutorial.

HISTORY
     The ns protocol family appeared in 4.3BSD.

4.3 Berkeley Distribution      November 30, 1993			     2
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server BSDOS

List of man pages available for BSDOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net