NETGROUP(5) BSD File Formats Manual NETGROUP(5)NAMEnetgroup — defines network groups
The netgroup file specifies ``netgroups'', which are sets of (host, user,
domain) tuples that are to be given similar network access.
Each line in the file consists of a netgroup name followed by a list of
the members of the netgroup. Each member can be either the name of
another netgroup or a specification of a tuple as follows:
(host, user, domain)
where the host, user, and domain are character string names for the cor‐
responding component. Any of the comma separated fields may be empty to
specify a ``wildcard'' value or may consist of the string ``-'' to spec‐
ify ``no valid value''. The members of the list may be separated by
whitespace and/or commas; the ``\'' character may be used at the end of a
line to specify line continuation. The functions specified in
getnetgrent(3) should normally be used to access the netgroup database.
Lines that begin with a # are treated as comments.
/etc/netgroup the netgroup database.
SEE ALSOgetnetgrent(3), exports(5)COMPATIBILITY
The file format is compatible with that of various vendors, however it
appears that not all vendors use an identical format.
The interpretation of access restrictions based on the member tuples of a
netgroup is left up to the various network applications. Also, it is not
obvious how the domain specification applies to the BSD environment.
BSD December 11, 1993 BSD