net_protocol_lookup man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_PROTOCOL_LOOKUP(9F)				       NET_PROTOCOL_LOOKUP(9F)

NAME
       net_protocol_lookup  - locate an implementation of a network layer pro‐
       tocol

SYNOPSIS
       #include <sys/neti.h>

       net_handle_t net_protocol_lookup(netid_t id, const char *protocol);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       id
		 network instance identifier.

       family
		 name of the network protocol to find.

DESCRIPTION
       The net_protocol_lookup() function attempts to locate a data  structure
       that  defines what capabilities it is exporting through this interface.
       The value returned by this call is guaranteed to be valid until	it  is
       passed  into  a call to net_protocol_release(9F), after which it should
       no longer be treated as valid.

       The protocol must be a registered name of a network protocol  that  has
       been registered. The symbols NHF_INET and NHF_INET6 should be passed to
       net_protocol_lookup() as the protocol name to  gain  access  to	either
       IPv4 or IPv6 respectively.

RETURN VALUES
       The net_protocol_lookup() function returns NULL if it does not find any
       knowledge about the network protocol referenced. Otherwise, it  returns
       a value that can be used with other calls in this framework.

CONTEXT
       The net_protocol_lookup() function may be called from user,  kernel, or
       interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_protocol_release(9F), attributes(5)

				  Mar 5, 2012	       NET_PROTOCOL_LOOKUP(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net