net_phylookup man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_PHYLOOKUP(9F)					     NET_PHYLOOKUP(9F)

NAME
       net_phylookup - determine if a network interface name exists for a net‐
       work protocol

SYNOPSIS
       #include <sys/neti.h>

       phy_if_t net_phylookup(const net_data_t net, const char *name);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net
	       value  returned	from   a   successful	call   to   net_proto‐
	       col_lookup(9F).

       name
	       name of the network interface to find.

DESCRIPTION
       The  net_phylookup()  function  attempts	 to resolve the interface name
       passed in with the network protocol.

       When called successfully,  the  value  returned	represents  a  network
       interface that exists, at the time of the call, within the scope of the
       network interface. This value is only guaranteed to  be	unique	for  a
       name within the scope of the network protocol.

RETURN VALUES
       The  net_phylookup()  function returns -1 if it is not supported by the
       network	protocol,  and 0 if the named network interface does not exist
       (or  is	otherwise  unknown).  Otherwise, it returns  a	value  greater
       than 0 representing a network interface that  currently	exists	within
       the scope of this network protocol.

CONTEXT
       The  net_phylookup()  function  may  be	called	from user,  kernel, or
       interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_getifname(9F),     net_phygetnext(9F),     net_protocol_lookup(9F),
       attributes(5)

				  May 1, 2008		     NET_PHYLOOKUP(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net