net_isvalidchecksum man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_ISVALIDCHECKSUM(9F)				       NET_ISVALIDCHECKSUM(9F)

NAME
       net_isvalidchecksum - verify layer 3 and layer 4	 checksums

SYNOPSIS
       #include <sys/neti.h>

       int net_isvalidchecksum(const net_data_t net, mblk_t *mb);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net
	      value   returned	 from	a   successful	 call	to  net_proto‐
	      col_lookup(9F).

       mb
	     the mblk structure holding a packet that is the subject  of  this
	     query.

DESCRIPTION
       The  net_isvalidchecksum() function verifies the layer 3 checksum (and,
       in some case, the layer 4 checksum) in the packet. If possible,	fields
       that  are used by hardware checksum'ing are examined rather than	 manu‐
       ally verifying that the checksums are present for packets received from
       a network interface.

       For  both  IPv4 and IPv6, TCP, UDP and ICMP (including ICMPV6 for IPv6)
       layer 4 checksums are currently validated.

RETURN VALUES
       The net_isvalidchecksum() function returns:

       -1
	     The network protocol does not support this function.

       0
	     The packet does not contain partial checksums.

       1
	     The packet does contain partial checksums.

CONTEXT
       The net_isvalidchecksum() function may be called from user,  kernel, or
       interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_ispartialchecksum(9F), net_protocol_lookup(9F), attributes(5)

				  May 1, 2008	       NET_ISVALIDCHECKSUM(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net