net_ispartialchecksum man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_ISPARTIALCHECKSUM(9F)			     NET_ISPARTIALCHECKSUM(9F)

NAME
       net_ispartialchecksum  -	 indicate  if  a packet is being scheduled for
       hardware checksum calculation

SYNOPSIS
       #include <sys/neti.h>

       int net_ispartialchecksum(const net_data_t net, mblk_t *mb);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net
	      value  returned	from   a   successful	call   to   net_proto‐
	      col_lookup(9F).

       mb
	     the  mblk	structure holding a packet that is the subject of this
	     query.

DESCRIPTION
       The net_ispartialchecksum() function looks at  the  fields  within  the
       mblk  structure	to  determine  if the packet contained inside contains
       headers with only partial checksum values. Partial checksum values  are
       stored  inside headers when the calculation of the complete checksum is
       being handled by the hardware.

RETURN VALUES
       The net_ispartialchecksum() function returns:

       -1
	     The network protocol does not support this function.

       0
	     The packet does not contain partial checksums.

       If a packet is marked for hardware checksum'ing, the  following	values
       are returned:

       NET_HCK_L3_FULL
			  Complete layer 3 checksum calculated

       NET_HCK_L3_PART
			  Partial layer 3 checksum calculated

       NET_HCK_L4_FULL
			  Complete layer 4 checksum calculated

       NET_HCK_L4_PART
			  Partial layer 4 checksum calculated

CONTEXT
       The  net_ispartialchecksum() function may be called from user,  kernel,
       or interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_isvalidchecksum(9F), net_protocol_lookup(9F), attributes(5)

				  May 1, 2008	     NET_ISPARTIALCHECKSUM(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net