net_instance_register man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_INSTANCE_REGISTER(9F)			     NET_INSTANCE_REGISTER(9F)

NAME
       net_instance_register  -	 register  a set of instances to occur with IP
       instance events

SYNOPSIS
       #include <sys/neti.h>

       int net_instance_register(net_instance_t *instances);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       instances
		    must be a pointer returned by net_instance_alloc(9F).

DESCRIPTION
       The net_instance_register() function attempts  to  record  the  set  of
       functions  passed  by  instances	 that  are  to be called when an event
       related to IP instance maintenance occurs.

RETURN VALUES
       If  the	net_instance_register()	 function  succeeds,  DDI_SUCCESS   is
       returned. Otherwise, DDI_FAILURE is returned to indicate failure due to
       the name in the instance already being present.

CONTEXT
       The net_instance_register() function may be called from user or	kernel
       context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_instance_alloc(9F),	 net_instance_unregister(9F),	attributes(5),
       net_instance_t(9S)

				  May 1, 2008	     NET_INSTANCE_REGISTER(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net