net_inject_t man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_INJECT_T(9S)					      NET_INJECT_T(9S)

NAME
       net_inject_t - structure for describing how to transmit a packet

SYNOPSIS
       #include <sys/neti.h>

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

DESCRIPTION
       The  net_inject_t  data	structure  passes information in to net_inject
       about how to transmit a packet. Transmit includes sending the packet up
       into the system as well as out of it.

STRUCTURE MEMBERS
	  mblk_t		  *ni_packet;	/* start of the packet */
	   struct sockaddr_storage ni_addr;	 /* address of next hop */
	   phy_if_t		   ni_physical;	 /* network interface to use */

       ni_packet
		      Pointer  to  the	first  the  mblk_t data structure that
		      makes up this packet.

       ni_addr
		      This  field  is  only  required  to  be  initialized  if
		      NI_DIRECT_OUT  is being used to transmit the packet. The
		      sockaddr_storage field must be set to  indicate  whether
		      the  destination	address	 contained in the structure is
		      IPv4 (cast ni_addr to struct sockaddr_in) or IPv6	 (cast
		      ni_addr to struct sockaddr_in6).

       ni_physical
		      The   physical   interface  where	 the  packet  will  be
		      injected.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_inject(9F), netinfo(9F), attributes(5)

				  May 1, 2008		      NET_INJECT_T(9S)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net