net_getpmtuenabled man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_GETPMTUENABLED(9F)					NET_GETPMTUENABLED(9F)

NAME
       net_getpmtuenabled  -  determine if path MTU discovery is enabled for a
       network protocol

SYNOPSIS
       #include <sys/neti.h>

       int net_getpmtuenabled(const net_data_t net);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net
	      value  returned	from   a   successful	call   to   net_proto‐
	      col_lookup(9F).

DESCRIPTION
       The  net_getpmtuenabled()  function returns a value to indicate whether
       or not path MTU (PMTU) discovery is enabled for this network protocol.

RETURN VALUES
       The net_getpmtuenabled() function returns:

       -1
	     The network protocol does not support this function.

       0
	     PATH MTU discovery is disabled.

       1
	     PATH MTU discovery is enabled.

CONTEXT
       The net_getpmtuenabled() function may be called from user,  kernel,  or
       interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_getmtu(9F), net_protocol_lookup(9F)

				  May 1, 2008		NET_GETPMTUENABLED(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net