MTREE(8) BSD System Manager's Manual MTREE(8)NAMEmtree — map a directory hierarchy
SYNOPSISmtree [-cderux] [-f spec] [-K keywords] [-k keywords] [-p path] [-s seed]
The utility mtree compares the file hierarchy rooted in the current
directory against a specification read from the standard input. Messages
are written to the standard output for any files whose characteristics do
not match the specifications, or which are missing from either the file
hierarchy or the specification.
The options are as follows:
-c Print a specification for the file hierarchy to the standard out‐
-d Ignore everything except directory type files.
-e Don't complain about files that are in the file hierarchy, but not
in the specification.
-f Read the specification from file, instead of from the standard
-K Add the specified (whitespace or comma separated) keywords to the
current set of keywords.
-k Use the ``type'' keyword plus the specified (whitespace or comma
separated) keywords instead of the current set of keywords.
-p Use the file hierarchy rooted in path, instead of the current
-r Remove any files in the file hierarchy that are not described in
-s Display a single checksum to the standard error output that repre‐
sents all of the files for which the keyword cksum was specified.
The checksum is seeded with the specified value.
-u Modify the owner, group, and permissions of existing files to match
the specification and create any missing directories. User, group,
and permissions must all be specified for missing directories to be
-x Don't descend below mount points in the file hierarchy.
Specifications are mostly composed of ``keywords'', i.e. strings that
that specify values relating to files. No keywords have default values,
and if a keyword has no value set, no checks based on it are performed.
Currently supported keywords are as follows:
cksum The checksum of the file using the default algorithm speci‐
fied by the cksum(1) utility.
ignore Ignore any file hierarchy below this file.
gid The file group as a numeric value.
gname The file group as a symbolic name.
mode The current file's permissions as a numeric (octal) or sym‐
nlink The number of hard links the file is expected to have.
uid The file owner as a numeric value.
uname The file group as a symbolic name.
size The size, in bytes, of the file.
link The file the symbolic link is expected to reference.
time The last modification time of the file.
type The type of the file; may be set to any one of the following:
block block special device
char character special device
file regular file
link symbolic link
The default set of keywords are gid, mode, nlink, size, slink, time, and
There are four types of lines in a specification.
The first type of line sets a global value for a keyword, and consists of
the string ``/set'' followed by whitespace, followed by sets of key‐
word/value pairs, separated by whitespace. Keyword/value pairs consist
of a keyword, followed by an equals sign (``=''), followed by a value,
without whitespace characters. Once a keyword has been set, its value
remains unchanged until either reset or unset.
The second type of line unsets keywords and consists of the string
``/unset'', followed by whitespace, followed by one or more keywords,
separated by whitespace.
The third type of line is a file specification and consists of a file
name, followed by whitespace, followed by zero or more whitespace sepa‐
rated keyword/value pairs. The file name may be preceded by whitespace
characters. The file name may contain any of the standard file name
matching characters (``['', ``]'', ``?'' or ``*''), in which case files
in the hierarchy will be associated with the first pattern that they
Each of the keyword/value pairs consist of a keyword, followed by an
equals sign (``=''), followed by the keyword's value, without whitespace
characters. These values override, without changing, the global value of
the corresponding keyword.
All paths are relative. Specifying a directory will cause subsequent
files to be searched for in that directory hierarchy. Which brings us to
the last type of line in a specification: a line containing only the
string “..” causes the current directory path to ascend one level.
Empty lines and lines whose first non-whitespace character is a hash mark
(``#'') are ignored.
The mtree utility exits with a status of 0 on success, 1 if any error
occurred, and 2 if the file hierarchy did not match the specification.
To detect system binaries that have been ``trojan horsed'', it is recom‐
mended that mtree be run on the file systems, and a copy of the results
stored on a different machine, or, at least, in encrypted form. The seed
for the -s option should not be an obvious value and the final checksum
should not be stored on-line under any circumstances! Then, periodi‐
cally, mtree should be run against the on-line specifications and the
final checksum compared with the previous value. While it is possible
for the bad guys to change the on-line specifications to conform to their
modified binaries, it shouldn't be possible for them to make it produce
the same final checksum value. If the final checksum value changes, the
off-line copies of the specification can be used to detect which of the
binaries have actually been modified.
The -d and -u options can be used in combination to create directory
hierarchies for distributions and other such things.
/etc/mtree system specification directory
SEE ALSOchmod(1), chown(1), chgrp(1), cksum(1), stat(2), fts(3),
The mtree utility appeared in 4.3BSD-Reno.
BSD December 11, 1993 BSD