MOUNT_UMAP(8) BSD System Manager's Manual MOUNT_UMAP(8)NAMEmount_umap — sample file system layer
SYNOPSISmount_umap [-o options] target mount-point uid-mapfile gid-mapfile
The mount_umap command is used to mount a sub-tree of an existing file
system that uses a different set of uids and gids than the local system.
Such a file system could be mounted from a remote site via NFS or it
could be a file system on removable media brought from some foreign loca‐
tion that uses a different password file.
The options are as follows:
-o Options are specified with a -o flag followed by a comma sepa‐
rated string of options. See the mount(8) man page for possible
options and their meanings.
The mount_umap command uses a set of files provided by the user to make
correspondences between uids and gids in the sub-tree's original environ‐
ment and some other set of ids in the local environment. For instance,
user smith might have uid 1000 in the original environment, while having
uid 2000 in the local environment. The mount_umap command allows the
subtree from smith's original environment to be mapped in such a way that
all files with owning uid 1000 look like they are actually owned by uid
target should be the current location of the sub-tree in the local sys‐
tem's name space. mount-point should be a directory where the mapped
subtree is to be placed. uid-mapfile and gid-mapfile describe the map‐
pings to be made between identifiers. Briefly, the format of these files
is a count of the number of mappings on the first line, with each subse‐
quent line containing a single mapping. Each of these mappings consists
of an id from the original environment and the corresponding id in the
local environment, separated by white space. uid-mapfile should contain
all uid mappings, and gid-mapfile should contain all gid mappings. Any
uids not mapped in uid-mapfile will be treated as user NOBODY, and any
gids not mapped in gid-mapfile will be treated as group NULLGROUP. At
most 64 uids can be mapped for a given subtree, and at most 16 groups can
be mapped by a given subtree.
The mapfiles can be located anywhere in the file hierarchy, but they must
be owned by root, and they must be writable only by root. mount_umap
will refuse to map the sub-tree if the ownership or permissions on these
files are improper. It will also balk if the count of mappings in the
first line of the map files is not correct.
The layer created by the mount_umap command is meant to serve as a simple
example of file system layering. It is not meant for production use.
The implementation is not very sophisticated.
SEE ALSOmount(8), mount_null(8)HISTORY
The mount_umap utility first appeared in 4.4BSD.
4.4BSD September 28, 2021 4.4BSD