mount_nfs man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

MOUNT_NFS(8)		  BSD System Manager's Manual		  MOUNT_NFS(8)

NAME
     mount_nfs - mount nfs file systems

SYNOPSIS
     mount_nfs [-23KPTUbcdilqs] [-D deadthresh] [-I readdirsize] [-L
	       leaseterm] [-R retrycnt] [-a maxreadahead] [-g maxgroups] [-m
	       realm] [-o options] [-o port=value] [-r readsize] [-t timeout]
	       [-w writesize] [-x retrans] rhost:path node

DESCRIPTION
     The mount_nfs command calls the mount(2) system call to prepare and graft
     a remote nfs file system (rhost:path) on to the file system tree at the
     point node. This command is normally executed by mount(8).	 It implements
     the mount protocol as described in RFC 1094, Appendix A.  Options can be
     specified as a single letter flag, with an optional value, in the stan-
     dard getopt(3) style.  Alternatively, options can be given as arguments
     via the -o flag.  In this form, a long name can be used; if a value is
     required, it should appear following an equals sign, e.g., -o rsize=1024.
     The long forms below appear in brackets.

     For more information, see NFS: Network File System Version 3 Protocol
     Specification, Appendix I.

     The options are:

     -2 [nfsv2]
	       Use the NFS Version 2 protocol.

     -3 [nfsv3]
	       Use the NFS Version 3 protocol.	By default, mount_nfs asks the
	       server for NFS Version 3 first; if the server replies that NFS
	       Version 3 is not supported, mount_nfs then tries NFS Version 2.
	       The -3 flag instructs mount_nfs not to fall back to NFS Version
	       2 if the server does not support NFS Version 3.

     -D [deadthresh]
	       Used with NQNFS to set the ``dead server threshold'' to the
	       specified number of round trip timeout intervals.  After a
	       ``dead server threshold'' of retransmit timeouts, cached data
	       for the unresponsive server is assumed to still be valid.  Val-
	       ues may be set in the range of 1 - 9, with 9 referring to an
	       ``infinite dead threshold'' (i.e. never assume cached data
	       still valid).  This option is not generally recommended and is
	       really an experimental feature.

     -I [readdirsize]
	       Set the readdir read size to the specified value.  The value
	       should normally be a multiple of DIRBLKSIZ (normally 512 bytes)
	       that is less than or equal to the read size for the mount.

     -K [kerb]
	       Pass Kerberos authenticators to the server for client-to-server
	       user-credential mapping.	 This requires that the kernel be
	       built with the NFSKERB option.  (Refer to the INTERNET-DRAFT
	       titled Authentication Mechanisms for ONC RPC, for more informa-
	       tion.)

     -L [leaseterm]
	       Used with NQNFS to set the lease term to the specified number
	       of seconds.  Only use this argument for mounts with a large
	       round trip delay.  Values are normally in the 10-30 second

	       range.

     -P [resvport]
	       Use a reserved socket port number.  This is useful for mounting
	       servers that require clients to use a reserved port number on
	       the mistaken belief that this makes NFS more secure. (For the
	       rare case where the client has a trusted root account but un-
	       trustworthy users and the network cables are in secure areas
	       this does help, but for normal desktop clients this does not
	       apply.)

     -R [retry]
	       Set the retry count for doing the mount to the specified value.

     -T [tcp]  Use TCP transport instead of UDP.  This is recommended for
	       servers that are not on the same LAN cable as the client.  (NB:
	       This is NOT supported by most non-BSD servers.)

     -U	       Force the mount protocol to use UDP transport, even for TCP NFS
	       mounts.	(Necessary for some old BSD servers.)

     -a [readahead]
	       Set the read-ahead count to the specified value.	 This may be
	       in the range of 0 - 4, and determines how many blocks will be
	       read ahead when a large file is being read sequentially.	 Try-
	       ing a value greater than 1 for this is suggested for mounts
	       with a large bandwidth * delay product.

     -b [bg]   If an initial attempt to contact the server fails, fork off a
	       child to keep trying the mount in the background.  Useful for
	       fstab(5),  where the filesystem mount is not critical to mul-
	       tiuser operation.

     -c [noconn]
	       For UDP mount points, do not do a connect(2).  This must be
	       used for servers that do not reply to requests from the stan-
	       dard NFS port number 2049.

     -d [dumbtimer]
	       Turn off the dynamic retransmit timeout estimator.  This may be
	       useful for UDP mounts that exhibit high retry rates, since it
	       is possible that the dynamically estimated timeout interval is
	       too short.

     -g [maxgrps]
	       Set the maximum size of the group list for the credentials to
	       the specified value.  This should be used for mounts on old
	       servers that cannot handle a group list size of 16, as speci-
	       fied in RFC 1057.  Try 8, if users in a lot of groups cannot
	       get response from the mount point.

     -i [intr]
	       Make the mount interruptible.  If the current process performs
	       a file system operation that is delayed (typically due to an
	       unresponsive server), that operation will return immediately
	       with an error when certain signals are sent to the process.
	       The signals that may interrupt NFS operations are SIGHUP,
	       SIGINT, SIGQUIT, SIGTERM and SIGKILL. If the current process
	       blocks or ignores a signal, that signal will not interrupt an
	       NFS operation; a caught signal may interrupt an NFS operation,
	       however.	 Programs that are executed from an interruptible
	       mount can dump core if a signal causes a paging operation to
	       fail, so it is recommended that interruptible mounts also set
	       noexec.

     -l [rdirplus]
	       Used with NQNFS and NFSV3 to specify that the ReaddirPlus RPC
	       should be used.	This option reduces RPC traffic for cases such
	       as ``ls -l'', but tends to flood the attribute and name caches
	       with prefetched entries.	 Try this option and see whether per-
	       formance improves or degrades. Probably most useful for client
	       to server network interconnects with a large bandwidth times
	       delay product.

     -m [realm]
	       Set the Kerberos realm to the string argument.  Used with the
	       -K option for mounts to other realms.

     -o	       Options are specified with a -o flag followed by a comma sepa-
	       rated string of options.	 See the mount(8) man page for possi-
	       ble options and their meanings.

     -o port=value
	       Set the port to use to the specified value.  By default the
	       port used is determined by the portmapper (see portmap(8)).

     -q [nqnfs]
	       Use the leasing extensions to the NFS Version 3 protocol to
	       maintain cache consistency.  This protocol version 2 revision
	       to Not Quite Nfs (NQNFS) is only supported by this updated re-
	       lease of NFS code.  It is not backwards compatible with the
	       version 1 NQNFS protocol that was part of the first release of
	       4.4BSD-Lite.  To interoperate with a first release 4.4BSD-Lite
	       NFS system you will have to avoid this option until you have
	       had an opportunity to upgrade the NFS code to release 2 of
	       4.4BSD-Lite on all your systems.

     -r [rsize]
	       Set the read data size to the specified value.  It should nor-
	       mally be a power of 2 greater than or equal to 1024.  This
	       should be used for UDP mounts when the ``fragments dropped due
	       to timeout'' value is getting large while actively using a
	       mount point.  (Use netstat(1) with the -s option to see what
	       the ``fragments dropped due to timeout'' value is.)  See the -w
	       option as well.

     -s [soft]
	       A soft mount, which implies that file system calls will fail
	       after Retry round trip timeout intervals.

     -t [timeo]
	       Set the initial retransmit timeout to the specified value.  May
	       be useful for fine tuning UDP mounts over internetworks with
	       high packet loss rates or an overloaded server.	Try increasing
	       the interval if nfsstat(1) shows high retransmit rates while
	       the file system is active or reducing the value if there is a
	       low retransmit rate but long response delay observed.  (Normal-
	       ly, the -d option should be specified when using this option to
	       manually tune the timeout interval.)

     -w [wsize]
	       Set the write data size to the specified value.	Similar to the
	       -r option, but using the ``fragments dropped due to timeout''
	       value on the server instead of the client.  Note that both the
	       -r and -w options should only be used as a last ditch effort at
	       improving performance when mounting servers that do not support
	       TCP mounts.

     -x [retrans]
	       Set the retransmit timeout count for soft mounts to the speci-
	       fied value.

SEE ALSO
     mount(2),	unmount(2),  fstab(5),	mount(8),  portmap(8)

BUGS
     Due to the way that Sun RPC is implemented on top of UDP (unreliable
     datagram) transport, tuning such mounts is really a black art that can
     only be expected to have limited success.	For clients mounting servers
     that are not on the same LAN cable or that tend to be overloaded, TCP
     transport is strongly recommended, but unfortunately this is restricted
     to mostly 4.4BSD servers.

4.4BSD			       January 14, 1998				     4
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net