mount man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

MOUNT(8)		  BSD System Manager's Manual		      MOUNT(8)

NAME
     mount - mount file systems

SYNOPSIS
     mount [-adfruvw] [-t ufs | lfs | external_type]
     mount [-dfruvw] special | node
     mount [-dfruvw] [-o options] [-t ufs | lfs | external_type] special node

DESCRIPTION
     The mount command calls the mount(2) system call to prepare and graft a
     special device or the remote node (rhost:path) on to the file system tree
     at the point node. If node contains a symbolic link, the real pathname of
     the node is used as the mount point.  If either special or node are not
     provided, the appropriate information is taken from the fstab(5) file.

     The system maintains a list of currently mounted file systems.  If no ar-
     guments are given to mount, this list is printed, one line per mounted
     filesystem.  The output includes any flags that are currently in effect
     for the filesystem.  See the description of the -o flag below for the set
     of possible flags.	 If the filesystem was mounted by a user other than
     root, the user identifier of the process that did the mount is listed.
     Finally, the command lists the number of synchronous and asynchronous
     write operations that have been done by the filesystem since the time it
     was mounted.  If a filesystem is mounted read-write and later read-only,
     then the command lists the writes done while the filesystem was mounted
     read-write.

     The options are as follows:

     -a	     All the filesystems described in the fstab file (see fstab(5))
	     are mounted, except those marked as ``noauto'', or those excluded
	     using the -t option to indicate that only filesystems of the
	     specified type should be mounted.

     -d	     Causes everything to be done except for the actual system call.
	     This option is useful in conjunction with the -v flag to deter-
	     mine what the mount command is trying to do.

     -f	     Forces the revocation of write access when trying to downgrade a
	     filesystem mount status from read-write to read-only.

     -o	     Options are specified with a -o flag followed by a comma separat-
	     ed string of options.  The following options are available:

	     async   All I/O to the file system should be done asynchronously.

		     Note: this is a dangerous flag to set, and should not be
		     used unless you are prepared to recreate the file system
		     from scratch if your system crashes.

	     force   The same as -f; forces the revocation of write access
		     when trying to downgrade a filesystem mount status from
		     read-write to read-only.

	     noaccesstime
		     File access times are not updated.

		     This is a performance optimization for filesystems used
		     for largely read-only, short-lived data, e.g., news.

	     noauto  This filesystem should be skipped when mount is run with

		     the -a flag.

	     nodev   Do not interpret character or block special devices on
		     the file system.  This option is useful for a server that
		     has file systems containing special devices for architec-
		     tures other than its own.

	     noexec  Do not allow execution of any binaries on the mounted
		     file system.  This option is useful for a server that has
		     file systems containing binaries for architectures other
		     than its own.

	     nosuid  Do not allow set-user-identifier or set-group-identifier
		     bits to take effect.

	     rdonly  The same as -r; mount the file system read-only (even the
		     super-user may not write it).

	     softrdonly
		     Periodically check to see if any files are open for writ-
		     ing on the filesystem.  If none exist, downgrade the
		     filesystem to read-only.  When an open for writing is
		     made, upgrade the filesystem back to read-write.  The
		     benefit of this option is that quiescent filesystems will
		     be marked clean and consequently will not need to have
		     fsck(8) run on them after a crash.

	     sync    All I/O to the file system should be done synchronously.

	     update  The same as -u; indicate that the status of an already
		     mounted file system should be changed.

	     union   Causes the namespace at the mount point to appear as the
		     union of the mounted filesystem root and the existing di-
		     rectory.  Lookups will be done in the mounted filesystem
		     first.  If those operations fail due to a non-existent
		     file the underlying directory is then accessed.  All cre-
		     ates are done in the mounted filesystem.

	     Any additional options specific to a filesystem type that is not
	     one of the internally known types (see the -t option) may be
	     passed as a comma separated list; these options are distinguished
	     by a leading ``-'' (dash).	 Options that take a value are speci-
	     fied using the syntax -option=value.  For example, the mount com-
	     mand:

		   mount -t mfs -o nosuid,-N,-s=4000 /dev/dk0b /tmp

	     causes mount to execute the equivalent of:

		   /sbin/mount_mfs -o nosuid -N -s 4000 /dev/dk0b /tmp

     -r	     The file system is to be mounted read-only.  Mount the file sys-
	     tem read-only (even the super-user may not write it).  The same
	     as the ``rdonly'' argument to the -o option.

     -t ufs | lfs | external type
	     The argument following the -t is used to indicate the file system
	     type.  When -a is not used, ufs is the default.  With -a, the de-
	     fault is to include all file system types.	 The -t option can be
	     used to indicate that the actions should only be taken on
	     filesystems of the specified type.	 More than one type may be
	     specified in a comma separated list.  The list of filesystem
	     types can be prefixed with ``no'' to specify the filesystem types
	     for which action should not be taken.  For example, the mount
	     command:

		   mount -a -t nonfs,nomfs

	     mounts all filesystems except those of type NFS and MFS.

	     If the type is not one of the internally known types, mount will
	     attempt to execute a program in /sbin/mount_XXX where XXX is re-
	     placed by the type name.  For example, nfs filesystems are mount-
	     ed by the program /sbin/mount_nfs.

     -u	     The -u flag indicates that the status of an already mounted file
	     system should be changed.	Any of the options discussed above
	     (the -o option) may be changed; also a file system can be changed
	     from read-only to read-write or vice versa.  An attempt to change
	     from read-write to read-only will fail if any files on the
	     filesystem are currently open for writing unless the -f flag is
	     also specified.  The set of options is determined by first ex-
	     tracting the options for the file system from the fstab table,
	     then applying any options specified by the -o argument, and fi-
	     nally applying the -r or -w option.

     -v	     Verbose mode.

     -w	     The file system object is to be read and write.

     The options specific to NFS filesystems are described in the mount_nfs(8)
     manual page.  Similarly, options specific to other file systems can be
     found in their respective manual pages.

FILES
     /etc/fstab	 file system table

SEE ALSO
     mount(2),	realpath(3),  fstab(5),	 mount_cd9660(8),  mount_fdesc(8),
     mount_kernfs(8),  mount_lfs(8),  mount_msdos(8),  mount_mfs(8),
     mount_nfs(8),  mount_null(8),  mount_portal(8),  mount_procfs(8),
     mount_umap(8),  mount_union(8),  umount(8)

HISTORY
     A mount command appeared in Version 6 AT&T UNIX.

4th Berkeley Distribution	 May 24, 1996				     3
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net