memcpy man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

MEMCPY(9)		 BSD Kernel Developer's Manual		     MEMCPY(9)

NAME
     memcpy — copy byte string

SYNOPSIS
     #include <sys/systm.h>

     void *
     memcpy(void * restrict dst, const void * restrict src, size_t len);

DESCRIPTION
     The memcpy() function copies len bytes from string src to string dst.
     The arguments must not overlap -- behavior if the arguments overlap is
     undefined.	 To copy byte strings that overlap, use memmove(9).

RETURN VALUES
     The memcpy() function returns the original value of dst.

SEE ALSO
     memmove(9)

STANDARDS
     The memcpy() function conforms to ISO/IEC 9899:1999 (“ISO C99”).

BSD				January 2, 2012				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net