lkm man page on OpenBSD

Man page or keyword search:  
man Server   11362 pages
apropos Keyword Search (all sections)
Output format
OpenBSD logo
[printable version]

LKM(4)			  OpenBSD Programmer's Manual			LKM(4)

NAME
     LKM - Loadable Kernel Modules interface

SYNOPSIS
     option LKM

DESCRIPTION
     Loadable kernel modules allow the system administrator to dynamically add
     and remove functionality from a running system.  This ability also helps
     software developers to develop new parts of the kernel without constantly
     rebooting to test their changes.

     Various types of modules can be loaded into the system.  There are
     several defined module types, listed below, which can be added to the
     system in a predefined way.  In addition, there is a generic type, for
     which the module itself handles loading and unloading.

     The LKM interface is used by performing ioctl(2) calls on the /dev/lkm
     device.  Normally all operations involving Loadable Kernel Modules are
     handled by the modload(8), modunload(8), and modstat(8) programs.	Users
     should never have to interact with /dev/lkm directly.  The loading and
     unloading of modules is also dependent on the system securelevel(7).

MODULE TYPES
     System Call modules
	     System calls may be replaced by loading new ones via the LKM
	     interface.	 All system calls may be replaced, but special care
	     should be taken with the ioctl(2) system call, as it is used to
	     load and unload modules.

	     When a system call module is unloaded, the system call which was
	     replaced by the loadable module is returned to its rightful place
	     in the system call table.

     Virtual File System modules
	     Virtual file systems may be added via the LKM interface.

     Device Driver modules
	     New block and character device drivers may be loaded into the
	     system with LKM.  The major problem with loading a device driver
	     is that the driver's device nodes must exist for the devices to
	     be accessed.  They are usually created by instructing modload(8)
	     to run an appropriate program when the driver has been
	     successfully loaded.

     Execution Interpreters
	     Execution interpreters allow the loading and execution of
	     binaries which are normally not usable by the operating system.

     Miscellaneous modules
	     Miscellaneous modules are modules for which there are not
	     currently well-defined or well-used interfaces for extension.
	     The user is expected to write their own loader to manipulate
	     whatever kernel data structures necessary to enable and disable
	     the new module when it is loaded and unloaded.

FILES
     /dev/lkm			LKM interface device.
     /usr/include/sys/lkm.h	File containing definitions of module types.
     /usr/share/lkm		Example source code implementing several of
				the modules types.

SEE ALSO
     securelevel(7), modload(8), modstat(8), modunload(8)

HISTORY
     The LKM facility was designed to be similar in functionality to the
     loadable kernel modules facility provided by SunOS 4.1.3.

AUTHORS
     Terrence R. Lambert <terry@cs.weber.edu>

BUGS
     Loading a bogus module is likely to kill your machine.

     Loadable streams modules should and will be implemented when a streams
     implementation is written.

OpenBSD 4.9			August 2, 2008			   OpenBSD 4.9
[top]

List of man pages available for OpenBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net