kernacc man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

KERNACC(9)		 BSD Kernel Developer's Manual		    KERNACC(9)

NAME
     kernacc, useracc — check memory regions for accessibility

SYNOPSIS
     #include <sys/param.h>
     #include <sys/proc.h>
     #include <vm/vm.h>
     #include <vm/vm_extern.h>

     int
     kernacc(void *addr, int len, int rw);

     int
     useracc(void *addr, int len, int rw);

DESCRIPTION
     The kernacc() and useracc() functions check whether operations of the
     type specified in rw are permitted in the range of virtual addresses
     given by addr and len.  The possible values of rw are any bitwise combi‐
     nation of VM_PROT_READ, VM_PROT_WRITE and VM_PROT_EXECUTE.	 kernacc()
     checks addresses in the kernel address space, while useracc() considers
     addr to represent an user space address.  The process context to use for
     this operation is taken from the global variable curproc.

RETURN VALUES
     Both functions return boolean true if the type of access specified by rw
     is permitted.  Otherwise boolean false is returned.

BUGS
     The process pointer should be passed in as an argument to useracc().

BSD				 June 16, 1996				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net