kcopy man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

KCOPY(9)		 BSD Kernel Developer's Manual		      KCOPY(9)

NAME
     kcopy — copy data with abort on page fault

SYNOPSIS
     #include <sys/systm.h>

     int
     kcopy(const void *src, void *dst, size_t len);

DESCRIPTION
     kcopy() copies len bytes from src to dst, aborting if a fatal page fault
     is encountered.

     kcopy() must save and restore the old fault handler since it is called by
     uiomove(9), which may be in the path of servicing a non-fatal page fault.
     kcopy() returns 0 on success and an error number on failure.

SEE ALSO
     errno(2), memcpy(9), uiomove(9)

BSD				 April 4, 2006				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net