itimerfix man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

ITIMERFIX(9)		 BSD Kernel Developer's Manual		  ITIMERFIX(9)

NAME
     itimerfix — check that a timeval value is valid, and correct

SYNOPSIS
     #include <sys/time.h>

     int
     itimerfix(struct timeval *tv);

DESCRIPTION
     The itimerfix function checks that the value in tv is valid (0 ≤
     tv->tv_sec &&  0 ≤ tv->tv_usec < 1000000), and that the total time repre‐
     sented is at least one tick, or zero.

     If the total represented time is nonzero and smaller than tick, it is
     adjusted to exactly one tick.

RETURN VALUES
     itimerfix returns 0 on success or EINVAL if tv is invalid.

SEE ALSO
     nanosleep(2), poll(2), select(2), setitimer(2)

BSD			       November 23, 2001			   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net