irda man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

IRFRAME(4)		 BSD Kernel Interfaces Manual		    IRFRAME(4)

NAME
     irframe — IrDA frame level driver

SYNOPSIS
     irframe* at oboe?
     irframe* at uirda?
     irframe* at ustir?
     pseudo-device irframetty

     #include <dev/irdaio.h>

DESCRIPTION
     The irframe driver provides support for IrDA frame level transmission.
     It does not contain the IrDA protocol stack per se, but the stack can be
     built on top of the irframe driver.

     Access to frames is via the read(2) and write(2) system calls.  Each
     write constitutes one frame, and each read yields one frame.  The poll(2)
     system call can be used to check for availability of frames.  There are
     also a number of ioctl(2) calls to manipulate the device:

     IRDA_RESET_PARAMS
	     Reset the parameters set by IRDA_SET_PARAMS.

     IRDA_SET_PARAMS (struct irda_params)
	     Set the speed, extra beginning of frame bytes, and maximum frame
	     size.

     IRDA_GET_SPEEDMASK (int)
	     Get the set of allowable speeds.

     IRDA_GET_TURNAROUNDMASK (int)
	     Get the set of allowable turn around times.

SEE ALSO
     cir(4), irframetty(4), oboe(4), uirda(4), ustir(4)

     comms/birda package

HISTORY
     The irframe driver appeared in NetBSD 1.6.

BSD			       December 2, 2001				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net